Maven依赖指定版本范围或者最新版本

在maven中我们经常像下面这样引用一个依赖:

<dependency>
    <groupId>commons-lang</groupId>
    <artifactId>commons-lang</artifactId>
    <version>1.2.3</version>
</dependency>

我们指定了固定的版本1.2.3,如果我们想每次都引用最新版本,是否可以呢?
答案是可以的。

在pom文件的定义中,可以使用版本的一个范围,版本范围的写法说明如下:

  • (,1.0] x <= 1.0
  • 1.0 "Soft" requirement on 1.0 (just a recommendation - helps select the correct version if it matches all ranges)
  • [1.0] Hard requirement on 1.0
  • [1.2,1.3] 1.2 <= x <= 1.3
  • [1.0,2.0) 1.0 <= x < 2.0
  • [1.5,) x >= 1.5
  • (,1.0],[1.2,) x <= 1.0 or x >= 1.2. Multiple sets are comma-separated
  • (,1.1),(1.1,) This excludes 1.1 if it is known not to work in combination with this library

都是一些很简单的英文,我就不做翻译了。

来源:http://outofmemory.cn/code-snippet/12469/maven-specify-version-range


» 本文链接:https://blog.java-zone.org/archives/1159.html
» 转载请注明来源:Java地带  » 《Maven依赖指定版本范围或者最新版本》

» 本文章为Java地带整理创作,欢迎转载!转载请注明本文地址,谢谢!
» 部分内容收集整理自网络,如有侵权请联系我删除!

» 订阅本站:https://blog.java-zone.org/feed/

标签: Java, Maven

添加新评论